CVE-2012-5887 — tomcat
CVE-2012-5887 is a Improper Authentication vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 12.1% (96th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Authentication in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2012-5887.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.36, 6.x before 6.0.36, and 7.x before 7.0.30 does not properly check for stale nonce values in conjunction with enforcement of proper credentials, which makes it easier for remote attackers to bypass intended access restrictions by sniffing the network for valid requests.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.36 | 5.5.36org.apache.tomcat:tomcat:5.5.36 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.36 | 6.0.36org.apache.tomcat:tomcat:6.0.36 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.30 | 7.0.30org.apache.tomcat:tomcat:7.0.30 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 5.5.36 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-5887 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| JBEWP 5 for RHEL 5 | jbossweb-0:2.1.13-3_patch_02.ep5.el5 | RHSA-2013:0631 |
| JBoss Data Grid 6.1 | see advisory | RHSA-2013:0665 |
| JBoss Enterprise BRMS Platform 5.3 | see advisory | RHSA-2013:1006 |
| Red Hat Enterprise Linux 5 | tomcat5-0:5.5.23-0jpp.38.el5_9 | RHSA-2013:0640 |
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-52.el6_4 | RHSA-2013:0623 |
| Red Hat JBoss Enterprise Application Platform 5.2 | see advisory | RHSA-2013:0632 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 5 | jbossweb-0:2.1.13-3_patch_02.ep5.el5 | RHSA-2013:0629 |
| Red Hat JBoss Enterprise Application Platform 6.0 | see advisory | RHSA-2013:0648 |
Frequently Asked Questions
Is CVE-2012-5887 in your dependencies?
Find it across Maven, including transitive dependencies.