CVE-2012-3544 — tomcat
CVE-2012-3544 is a Improper Input Validation vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 11.0% (96th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Apache Tomcat Vulnerable to Denial of Service (DoS) via Improper Handling of chunk extensions
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2012-3544.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat 6.x before 6.0.37 and 7.x before 7.0.30 does not properly handle chunk extensions in chunked transfer coding, which allows remote attackers to cause a denial of service by streaming data.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.37 | 6.0.37org.apache.tomcat:tomcat:6.0.37 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.30 | 7.0.30org.apache.tomcat:tomcat:7.0.30 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 6.0.37 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-3544 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This flaw affects Apache Tomcat 6.0.30 - 6.0.36 and 7.0.0 - 7.0.29. It does not affect JBoss Web.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss Enterprise Web Server 2 for RHEL 5 | apache-commons-daemon-eap6-1:1.0.15-4.redhat_1.ep6.el5 | RHSA-2013:1011 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 6 | apache-commons-daemon-eap6-1:1.0.15-4.redhat_1.ep6.el6 | RHSA-2013:1012 |
| Red Hat JBoss Web Server 2.0 | see advisory | RHSA-2013:1013 |
Frequently Asked Questions
Is CVE-2012-3544 in your dependencies?
Find it across Maven, including transitive dependencies.