CVE-2011-5064 — tomcat
CVE-2011-5064 is a CWE-310 vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Use of Hard-coded Cryptographic Key in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
DigestAuthenticator.java in the HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.12 uses Catalina as the hard-coded server secret (aka private key), which makes it easier for remote attackers to bypass cryptographic protection mechanisms by leveraging knowledge of this string, a different vulnerability than CVE-2011-1184.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.34 | 5.5.34org.apache.tomcat:tomcat:5.5.34 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.33 | 6.0.33org.apache.tomcat:tomcat:6.0.33 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.12 | 7.0.12org.apache.tomcat:tomcat:7.0.12 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 5.5.34 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-5064 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| JBEWP 5 for RHEL 5 | jbossweb-0:2.1.12-3_patch_03.2.ep5.el5 | RHSA-2012:0076 |
| JBoss Communications Platform 5.1 | see advisory | RHSA-2012:0078 |
| JBoss Enterprise BRMS Platform 5.1 | see advisory | RHSA-2012:0325 |
| Red Hat Enterprise Linux 5 | tomcat5-0:5.5.23-0jpp.22.el5_7 | RHSA-2011:1845 |
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-35.el6_1 | RHSA-2011:1780 |
| Red Hat JBoss Enterprise Application Platform 4.3 | see advisory | RHSA-2012:0041 |
| Red Hat JBoss Enterprise Application Platform 5.1 | see advisory | RHSA-2012:0075 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 5 | jbossweb-0:2.1.12-3_patch_03.2.ep5.el5 | RHSA-2012:0074 |
Frequently Asked Questions
Is CVE-2011-5064 in your dependencies?
Find it across Maven, including transitive dependencies.