CVE-2011-2526 — tomcat
Fix: apache/tomcat@1d372c8CVE-2011-2526 is a Improper Input Validation vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Input Validation in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.19, when sendfile is enabled for the HTTP APR or HTTP NIO connector, does not validate certain request attributes, which allows local users to bypass intended file access restrictions or cause a denial of service (infinite loop or JVM crash) by leveraging an untrusted web application.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | all versions | 5.5.34org.apache.tomcat:tomcat:5.5.34 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.33 | 6.0.33org.apache.tomcat:tomcat:6.0.33 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.19 | 7.0.19org.apache.tomcat:tomcat:7.0.19 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 5.5.34 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-2526 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The Red Hat Security Response Team has rated this issue as having low security impact, a future update may address this flaw.
| Product | Fixed in | Advisory |
|---|---|---|
| JBEWP 5 for RHEL 5 | jbossweb-0:2.1.12-3_patch_03.2.ep5.el5 | RHSA-2012:0076 |
| JBoss Communications Platform 5.1 | see advisory | RHSA-2012:0078 |
| JBoss Enterprise BRMS Platform 5.1 | see advisory | RHSA-2012:0325 |
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-35.el6_1 | RHSA-2011:1780 |
| Red Hat JBoss Enterprise Application Platform 4.3 | see advisory | RHSA-2012:0041 |
| Red Hat JBoss Enterprise Application Platform 5.1 | see advisory | RHSA-2012:0075 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 5 | jbossweb-0:2.1.12-3_patch_03.2.ep5.el5 | RHSA-2012:0074 |
| Red Hat JBoss Enterprise Web Server 1 for RHEL 5 | tomcat5-0:5.5.33-27_patch_07.ep5.el5 | RHSA-2012:0680 |
Frequently Asked Questions
Is CVE-2011-2526 in your dependencies?
Find it across Maven, including transitive dependencies.