NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2011-0013 — tomcat

Fix: apache/tomcat@58223c5

CVE-2011-0013 is a Cross-site Scripting (XSS) vulnerability in org.apache.tomcat:tomcat. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in Apache Tomcat

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
10.0%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
5.27%13.7%22.1%30.5%25.8%10.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in the HTML Manager Interface in Apache Tomcat 5.5 before 5.5.32, 6.0 before 6.0.30, and 7.0 before 7.0.6 allow remote attackers to inject arbitrary web script or HTML, as demonstrated via the display-name tag.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat≥ 5.5.0&&< 5.5.325.5.32org.apache.tomcat:tomcat:5.5.32
☕Mavenorg.apache.tomcat:tomcat≥ 6.0.0&&< 6.0.306.0.30org.apache.tomcat:tomcat:6.0.30
☕Mavenorg.apache.tomcat:tomcat≥ 7.0.0&&< 7.0.67.0.6org.apache.tomcat:tomcat:7.0.6

Affected Products

1 product · 65 configurations
Application
tomcatapache
65 versions
5.5.05.5.15.5.25.5.35.5.45.5.55.5.65.5.75.5.85.5.95.5.105.5.11
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat:tomcat to 5.5.32 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-0013 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 5tomcat5-0:5.5.23-0jpp.22.el5_7RHSA-2011:1845
Red Hat Enterprise Linux 6tomcat6-0:6.0.24-33.el6RHSA-2011:0791
Red Hat JBoss Enterprise Web Server 1 for RHEL 5ant-0:1.7.1-13.jdk6.ep5.el5RHSA-2011:0897
Red Hat JBoss Web Server 1.0see advisoryRHSA-2011:0896

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in the HTML Manager Interface in Apache Tomcat 5.5 before 5.5.32, 6.0 before 6.0.30, and 7.0 before 7.0.6 allow remote attackers to inject arbitrary web script or HTML, as demonstrated via the display-name tag.
O3 Security · Impact-Aware SCA

Is CVE-2011-0013 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2011-0013: tomcat XSS — Fixed in 5.5.32