CVE-2010-5098 — cms-frontend
Fix: TYPO3/typo3@3c5d152CVE-2010-5098 is a Cross-site Scripting (XSS) vulnerability in typo3/cms-frontend. A fix is available for typo3/cms-frontend — see the affected versions and patch details below.
TYPO3 Cross-site scripting (XSS) vulnerability in the FORM content object
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
typo3/cms-frontend🐘typo3/cms-frontend🐘typo3/cms-frontendReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the FORM content object in TYPO3 4.2.x before 4.2.16, 4.3.x before 4.3.9, and 4.4.x before 4.4.5, allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-frontend | ≥ 4.2.0&&< 4.2.16 | 4.2.16composer require typo3/cms-frontend:^4.2.16 |
| 🐘Packagist | typo3/cms-frontend | ≥ 4.4.0&&< 4.4.5 | 4.4.5composer require typo3/cms-frontend:^4.4.5 |
| 🐘Packagist | typo3/cms-frontend | ≥ 4.3.0&&< 4.3.9 | 4.3.9composer require typo3/cms-frontend:^4.3.9 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-frontend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-frontend to 4.2.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-5098 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2010-5098 in your dependencies?
Find it across Packagist, including transitive dependencies.