NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2010-3670 — cms-frontend

MEDIUMFix: TYPO3/typo3@09ab776

CVE-2010-3670 is a medium-severity (CVSS 4.8) CWE-326 vulnerability in typo3/cms-frontend. A fix is available for typo3/cms-frontend — see the affected versions and patch details below.

TYPO3 is vulnerable to insecure randomness during hash generation in forgot password function

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.69%1.04%0.1%0.5%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘typo3/cms-frontend🐘typo3/cms-frontend

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

TYPO3 before 4.3.4 and 4.4.x before 4.4.1 contains insecure randomness during generation of a hash with the "forgot password" function.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-frontendall versions4.3.4composer require typo3/cms-frontend:^4.3.4
🐘Packagisttypo3/cms-frontend≥ 4.4.0&&< 4.4.14.4.1composer require typo3/cms-frontend:^4.4.1

Affected Products

1 product · 2 configurations
Application
typo3typo3
≥ 4.4.0 && < 4.4.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-frontend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-frontend to 4.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3670 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

TYPO3 before 4.3.4 and 4.4.x before 4.4.1 contains insecure randomness during generation of a hash with the "forgot password" function.
O3 Security · Impact-Aware SCA

Is CVE-2010-3670 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2010-3670: cms-frontend — Fixed in 4.3.4