NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2010-5097 — cms-frontend

CVE-2010-5097 is a Cross-site Scripting (XSS) vulnerability in typo3/cms-frontend. A fix is available for typo3/cms-frontend — see the affected versions and patch details below.

TYPO3 Cross-site scripting (XSS) vulnerability in the click enlarge functionality

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.15%0.81%1.47%2.13%0.7%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘typo3/cms-frontend🐘typo3/cms-frontend

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the click enlarge functionality in TYPO3 4.3.x before 4.3.9 and 4.4.x before 4.4.5 when the caching framework is enabled, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-frontend≥ 4.3.0&&< 4.3.94.3.9composer require typo3/cms-frontend:^4.3.9
🐘Packagisttypo3/cms-frontend≥ 4.4.0&&< 4.4.54.4.5composer require typo3/cms-frontend:^4.4.5

Affected Products

1 product · 14 configurations
Application
typo3typo3
14 versions
4.3.04.3.14.3.24.3.34.3.44.3.54.3.64.3.74.3.84.44.4.14.4.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-frontend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-frontend to 4.3.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-5097 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the click enlarge functionality in TYPO3 4.3.x before 4.3.9 and 4.4.x before 4.4.5 when the caching framework is enabled, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2010-5097 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2010-5097: cms-frontend XSS — Fixed in 4.3.9