CVE-2010-4172 — tomcat
Fix: apache/tomcat@5971f93CVE-2010-4172 is a Cross-site Scripting (XSS) vulnerability in org.apache.tomcat:tomcat. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Neutralization of Input During Web Page Generation in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site scripting (XSS) vulnerabilities in the Manager application in Apache Tomcat 6.0.12 through 6.0.29 and 7.0.0 through 7.0.4 allow remote attackers to inject arbitrary web script or HTML via the (1) orderBy or (2) sort parameter to sessionsList.jsp, or unspecified input to (3) sessionDetail.jsp or (4) java/org/apache/catalina/manager/JspHelper.java, related to use of untrusted web applications.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.5 | 7.0.5org.apache.tomcat:tomcat:7.0.5 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.12 | No fix |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Tomcat 7.0.4 - 'sort' / 'orderBy' Cross-Site Scripting
by Adam Muntner · Nov 22, 2010
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 7.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-4172 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-33.el6 | RHSA-2011:0791 |
| Red Hat JBoss Enterprise Web Server 1 for RHEL 5 | ant-0:1.7.1-13.jdk6.ep5.el5 | RHSA-2011:0897 |
| Red Hat JBoss Web Server 1.0 | see advisory | RHSA-2011:0896 |
Frequently Asked Questions
Is CVE-2010-4172 in your dependencies?
Find it across Maven, including transitive dependencies.