CVE-2010-1157 — tomcat
CVE-2010-1157 is a Information Exposure vulnerability in org.apache.tomcat:tomcat. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat 5.5.0 through 5.5.29 and 6.0.0 through 6.0.26 might allow remote attackers to discover the server's hostname or IP address by sending a request for a resource that requires (1) BASIC or (2) DIGEST authentication, and then reading the realm field in the WWW-Authenticate header in the reply.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.30 | 5.5.30org.apache.tomcat:tomcat:5.5.30 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.28 | 6.0.28org.apache.tomcat:tomcat:6.0.28 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Tomcat 5.5.0 < 5.5.29 / 6.0.0 < 6.0.26 - Information Disclosure
by Deniz Cevik · Apr 22, 2010
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 5.5.30 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-1157 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The risks associated with fixing this flaw are greater than the low severity security risk. We therefore have no plans to fix this flaw. The information leak can be avoided by adjusting the configuration to always specify a realm-name.
| Product | Fixed in | Advisory |
|---|---|---|
| JBEAP 4.2.0 for RHEL 5 | jbossweb-0:2.0.0-6.CP14.0jpp.ep1.1.el5 | RHSA-2010:0584 |
| Red Hat JBoss Enterprise Web Server 1 for RHEL 5 | ant-0:1.7.1-13.jdk6.ep5.el5 | RHSA-2011:0897 |
| Red Hat JBoss Web Server 1.0 | see advisory | RHSA-2011:0896 |
Frequently Asked Questions
Is CVE-2010-1157 in your dependencies?
Find it across Maven, including transitive dependencies.