CVE-2009-2902 — tomcat
Fix: apache/tomcat@3e1010bCVE-2009-2902 is a Path Traversal vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 10.7% (96th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Directory traversal vulnerability in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20 allows remote attackers to delete work-directory files via directory traversal sequences in a WAR filename, as demonstrated by the ...war filename.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.29 | 5.5.29org.apache.tomcat:tomcat:5.5.29 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.24 | 6.0.24org.apache.tomcat:tomcat:6.0.24 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 5.5.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-2902 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The Red Hat Product Security has rated this issue as having low security impact, a future update may address this flaw. More information regarding issue severity can be found here: https://access.redhat.com/security/updates/classification/
| Product | Fixed in | Advisory |
|---|---|---|
| JBEWS 1.0 for RHEL 4 | glassfish-jsf-0:1.2_13-2.ep5.el4 | RHSA-2010:0119 |
| Red Hat Certificate System 7.3 | tomcat5-0:5.5.23-0jpp_4rh.19 | RHSA-2010:0693 |
| Red Hat Enterprise Linux 5 | tomcat5-0:5.5.23-0jpp.9.el5_5 | RHSA-2010:0580 |
| RHAPS Version 2 for RHEL 4 | tomcat5-0:5.5.23-0jpp_4rh.17 | RHSA-2010:0582 |
Frequently Asked Questions
Is CVE-2009-2902 in your dependencies?
Find it across Maven, including transitive dependencies.