CVE-2009-2901 — tomcat
Fix: apache/tomcat@3e1010bCVE-2009-2901 is a CWE-264 vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Authentication in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The autodeployment process in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20, when autoDeploy is enabled, deploys appBase files that remain from a failed undeploy, which might allow remote attackers to bypass intended authentication requirements via HTTP requests.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.29 | 5.5.29org.apache.tomcat:tomcat:5.5.29 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.24 | 6.0.24org.apache.tomcat:tomcat:6.0.24 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 5.5.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-2901 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2009-2901 in your dependencies?
Find it across Maven, including transitive dependencies.