CVE-2008-2370 — tomcat
CVE-2008-2370 is a Path Traversal vulnerability in org.apache.tomcat:tomcat. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Apache Tomcat Path Traversal Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when a RequestDispatcher is used, performs path normalization before removing the query string from the URI, which allows remote attackers to conduct directory traversal attacks and read arbitrary files via a .. (dot dot) in a request parameter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 4.1.0&&< 4.1.38 | 4.1.38org.apache.tomcat:tomcat:4.1.38 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.27 | 5.5.27org.apache.tomcat:tomcat:5.5.27 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.18 | 6.0.18org.apache.tomcat:tomcat:6.0.18 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Tomcat 6.0.16 - 'RequestDispatcher' Information Disclosure
by Stefano Di Paola · Aug 1, 2008
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 4.1.38 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-2370 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| JBEAP 4.2.0 for RHEL 4 | jbossweb-0:2.0.0-5.CP07.0jpp.ep1.1.el4 | RHSA-2008:0877 |
| Red Hat Certificate System 7.3 | ant-0:1.6.5-1jpp_1rh | RHSA-2010:0602 |
| Red Hat Developer Suite V.3 | tomcat5-0:5.5.23-0jpp_12rh | RHSA-2008:0864 |
| Red Hat Enterprise Linux 5 | tomcat5-0:5.5.23-0jpp.7.el5_2.1 | RHSA-2008:0648 |
| Red Hat Network Satellite Server v 5.0 | tomcat5-0:5.0.30-0jpp_12rh | RHSA-2008:1007 |
| RHAPS Version 2 for RHEL 4 | tomcat5-0:5.5.23-0jpp_4rh.9 | RHSA-2008:0862 |
Frequently Asked Questions
Is CVE-2008-2370 in your dependencies?
Find it across Maven, including transitive dependencies.