NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2008-1947 — tomcat

Fix: apache/tomcat@ab6a6c4

CVE-2008-1947 is a Cross-site Scripting (XSS) vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.

Apache Tomcat Cross-site scripting (XSS) vulnerability

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
9.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.00%24.7%49.4%74.2%59.3%9.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Apache Tomcat 5.5.9 through 5.5.26 and 6.0.0 through 6.0.16 allows remote attackers to inject arbitrary web script or HTML via the name parameter (aka the hostname attribute) to host-manager/html/add.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat≥ 5.5.9&&< 5.5.275.5.27org.apache.tomcat:tomcat:5.5.27
☕Mavenorg.apache.tomcat:tomcat≥ 6.0.0&&< 6.0.186.0.18org.apache.tomcat:tomcat:6.0.18
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 5.5.9&&< 5.5.275.5.27org.apache.tomcat.embed:tomcat-embed-core:5.5.27
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 6.0.0&&< 6.0.186.0.18org.apache.tomcat.embed:tomcat-embed-core:6.0.18

Affected Products

1 product · 35 configurations
Application
tomcatapache
35 versions
5.5.95.5.105.5.115.5.125.5.135.5.145.5.155.5.165.5.175.5.185.5.195.5.20

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat:tomcat to 5.5.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-1947 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
Red Hat Developer Suite V.3tomcat5-0:5.5.23-0jpp_12rhRHSA-2008:0864
Red Hat Enterprise Linux 5tomcat5-0:5.5.23-0jpp.7.el5_2.1RHSA-2008:0648
Red Hat Network Satellite Server v 5.0tomcat5-0:5.0.30-0jpp_12rhRHSA-2008:1007
RHAPS Version 2 for RHEL 4tomcat5-0:5.5.23-0jpp_4rh.9RHSA-2008:0862

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Apache Tomcat 5.5.9 through 5.5.26 and 6.0.0 through 6.0.16 allows remote attackers to inject arbitrary web script or HTML via the name parameter (aka the hostname attribute) to `host-manager/html/add`.
O3 Security · Impact-Aware SCA

Is CVE-2008-1947 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2008-1947: tomcat XSS — Fixed in 5.5.27