NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2007-2450 — tomcat

Fix: apache/tomcat@1bc3bcb

CVE-2007-2450 is a Cross-site Scripting (XSS) vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.

Apache Tomcat vulnerable to Cross-site Scripting

Published
Updated
Affected
5 pkgs
Patched
3 / 5
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.60%1.71%2.81%3.91%1.2%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

5 pkgs affected
☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in the (1) Manager and (2) Host Manager web applications in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.24, and 6.0.0 through 6.0.13 allow remote authenticated users to inject arbitrary web script or HTML via a parameter name to manager/html/upload, and other unspecified vectors.

Affected Packages

5 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat≥ 4.0.0No fix
☕Mavenorg.apache.tomcat:tomcat≥ 4.1.0&&< 4.1.374.1.37org.apache.tomcat:tomcat:4.1.37
☕Mavenorg.apache.tomcat:tomcat≥ 5.0.0No fix
☕Mavenorg.apache.tomcat:tomcat≥ 5.5.0&&< 5.5.255.5.25org.apache.tomcat:tomcat:5.5.25
☕Mavenorg.apache.tomcat:tomcat≥ 6.0.0&&< 6.0.146.0.14org.apache.tomcat:tomcat:6.0.14

Affected Products

1 product · 88 configurations
Application
tomcatapache
87 versions
4.0.04.0.14.0.24.0.34.0.44.0.54.0.64.1.04.1.14.1.24.1.34.1.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2007-2450; check the affected-versions list above or the advisory for the patched release of org.apache.tomcat:tomcat, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
Red Hat Enterprise Linux 5tomcat5-0:5.5.23-0jpp.1.0.4.el5RHSA-2007:0569
Red Hat Network Satellite Server v 4.2jabberd-0:2.0s10-3.38.rhnRHSA-2008:0524
Red Hat Network Satellite Server v 5.0jabberd-0:2.0s10-3.38.rhnRHSA-2008:0261
RHAPS Version 2 for RHEL 4tomcat5-0:5.5.23-0jpp_4rh.4RHSA-2007:0876

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in the (1) Manager and (2) Host Manager web applications in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.24, and 6.0.0 through 6.0.13 allow remote authenticated users to inject arbitrary web script or HTML via a parameter name to manager/html/upload, and other unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2007-2450 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2007-2450: tomcat XSS — Fixed in 4.1.37