CVE-2006-7196 — tomcat
CVE-2006-7196 is a Cross-site Scripting (XSS) vulnerability in org.apache.tomcat:tomcat. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Cross-site scripting in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the calendar application example in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.31, 5.0.0 through 5.0.30, and 5.5.0 through 5.5.15 allows remote attackers to inject arbitrary web script or HTML via the time parameter to cal2.jsp and possibly unspecified other vectors. NOTE: this may be related to CVE-2006-0254.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 4.0.0&&< 4.0.7 | 4.0.7org.apache.tomcat:tomcat:4.0.7 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 4.1.0&&< 4.1.32 | 4.1.32org.apache.tomcat:tomcat:4.1.32 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.0.0&&< 5.0.31 | 5.0.31org.apache.tomcat:tomcat:5.0.31 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.16 | 5.5.16org.apache.tomcat:tomcat:5.5.16 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Tomcat 5.5.15 - cal2.jsp Cross-Site Scripting
by Tushar Vartak · Sep 4, 2007
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 4.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2006-7196 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Network Satellite Server v 4.2 | jabberd-0:2.0s10-3.38.rhn | RHSA-2008:0524 |
| Red Hat Network Satellite Server v 5.0 | jabberd-0:2.0s10-3.38.rhn | RHSA-2008:0261 |
| RHAPS Version 1 for RHEL 3 | tomcat5-0:5.0.30-0jpp_5rh | RHSA-2007:0340 |
| RHAPS Version 2 for RHEL 4 | jakarta-commons-modeler-0:2.0-3jpp_2rh | RHSA-2007:0326 |
Frequently Asked Questions
Is CVE-2006-7196 in your dependencies?
Find it across Maven, including transitive dependencies.