CVE-2005-3510 — tomcat
CVE-2005-3510 is a security vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Apache Tomcat Vulnerable to Denial of Service (DoS) via Simultaneous Requests
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat 5.5.0 to 5.5.11 allows remote attackers to cause a denial of service (CPU consumption) via a large number of simultaneous requests to list a web directory that has a large number of files.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.12 | 5.5.12org.apache.tomcat:tomcat:5.5.12 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 5.5.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2005-3510 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Application Server v2 4AS | see advisory | RHSA-2006:0161 |
| Red Hat Certificate System 7.3 | ant-0:1.6.5-1jpp_1rh | RHSA-2010:0602 |
| Red Hat Network Satellite Server v 4.0 | jakarta-commons-pool-0:1.2-2jpp_2rh | RHSA-2007:1069 |
| Red Hat Network Satellite Server v 4.2 | jabberd-0:2.0s10-3.38.rhn | RHSA-2008:0524 |
| Red Hat Network Satellite Server v 5.0 | jabberd-0:2.0s10-3.38.rhn | RHSA-2008:0261 |
| RHAPS Version 1 for RHEL 3 | tomcat5-0:5.0.30-0jpp_5rh | RHSA-2007:0340 |
Frequently Asked Questions
Is CVE-2005-3510 in your dependencies?
Find it across Maven, including transitive dependencies.