CakePHP vulnerable to Cross-site Scripting in some development error pagesGHSA-xwhj-pqcg-8rcr
Fix: cakephp/cakephp@1ea0c87GHSA-xwhj-pqcg-8rcr is a security vulnerability in cakephp/cakephp. A fix is available for cakephp/cakephp — see the affected versions and patch details below.
Real-World Exposure
cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only missing route and duplicate named route error pages.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | cakephp/cakephp | ≥ 3.4.0&&< 3.4.14 | 3.4.14composer require cakephp/cakephp:^3.4.14 |
| 🐘Packagist | cakephp/cakephp | ≥ 3.5.0&&< 3.5.17 | 3.5.17composer require cakephp/cakephp:^3.5.17 |
| 🐘Packagist | cakephp/cakephp | ≥ 3.6.0&&< 3.6.4 | 3.6.4composer require cakephp/cakephp:^3.6.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cakephp/cakephp to 3.4.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xwhj-pqcg-8rcr is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-xwhj-pqcg-8rcr in your dependencies?
Find it across Packagist, including transitive dependencies.