NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
HIGH severity

Panic mishandled in libpulse-bindingGHSA-xvcg-2q82-r87j

HIGHFix: jnqnfe/pulse-binding-rust@7fd282a

GHSA-xvcg-2q82-r87j is a high-severity (CVSS 7.5) vulnerability in libpulse-binding. A fix is available for libpulse-binding — see the affected versions and patch details below.

Also known asCVE-2019-25055GHSA-wcxc-jf6c-8rx9RUSTSEC-2019-0038
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.57%1.14%1.72%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🦀libpulse-binding

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iolibpulse-bindingall versions2.6.0cargo update -p libpulse-binding --precise 2.6.0

Affected Products

1 product · 1 configurations
Application
libpulse-bindinglibpulse-binding_project
< 2.6.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for libpulse-binding, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update libpulse-binding to 2.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xvcg-2q82-r87j is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.
O3 Security · Impact-Aware SCA

Is GHSA-xvcg-2q82-r87j in your dependencies?

Find it across crates.io, including transitive dependencies.

Panic mishandled in libpulse-binding (High 7.5)