CVE-2018-25001 — libpulse-binding
MEDIUMCVE-2018-25001 is a medium-severity (CVSS 6.5) Use After Free vulnerability in libpulse-binding. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for libpulse-binding — see the affected versions and patch details below.
Duplicate Advisory: Use after free in libpulse-binding
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
libpulse-bindingReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Duplicate Advisory
This advisory has been withdrawn because it is a duplicate of GHSA-f56g-chqp-22m9. This link is maintained to preserve external references.
Original Description
An issue was discovered in the libpulse-binding crate before 2.5.0 for Rust. proplist::Iterator can cause a use-after-free.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | libpulse-binding | ≥ 1.0.5&&< 2.5.0 | 2.5.0cargo update -p libpulse-binding --precise 2.5.0 |
Affected Products
libpulse-bindinglibpulse-binding_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for libpulse-binding, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update libpulse-binding to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-25001 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2018-25001 in your dependencies?
Find it across crates.io, including transitive dependencies.