GHSA-f56g-chqp-22m9 is a medium-severity (CVSS 6.5) Use After Free vulnerability in libpulse-binding. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for libpulse-binding — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
libpulse-bindingReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Overview
Version 2.5.0 of the libpulse-binding Rust crate, released on the 22nd of December 2018, fixed a potential use-after-free issue with property list iteration due to a lack of a lifetime constraint tying the lifetime of a proplist::Iterator to the Proplist object for which it was created. This made it possible for users, without experiencing a compiler error/warning, to destroy the Proplist object before the iterator, thus destroying the underlying C object the iterator works upon, before the iterator may be finished with it.
This advisory is being written retrospectively, having previously only been noted in the changelog. No CVE assignment was sought.
This impacts all versions of the crate before 2.5.0 back to 1.0.5. Before version 1.0.5 the function that produces the iterator was broken to the point of being useless.
Patches
Users are required to update to version 2.5.0 or newer.
Versions older than 2.5.0 have been yanked from crates.io as of the 22nd of October 2020.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | libpulse-binding | ≥ 1.0.5&&< 2.5.0 | 2.5.0cargo update -p libpulse-binding --precise 2.5.0 |
Affected Products
libpulse-bindinglibpulse-binding_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for libpulse-binding, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update libpulse-binding to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f56g-chqp-22m9 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is GHSA-f56g-chqp-22m9 in your dependencies?
Find it across crates.io, including transitive dependencies.