NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Withdrawn — this advisory has been retracted
🦀 crates.io
Not in CISA KEV

Duplicate Advisory: Uncaught Exception in libpulse-bindingGHSA-wcxc-jf6c-8rx9

Fix: jnqnfe/pulse-binding-rust@7fd282a

GHSA-wcxc-jf6c-8rx9 is a security vulnerability in libpulse-binding. A fix is available for libpulse-binding — see the affected versions and patch details below.

Also known asCVE-2019-25055GHSA-xvcg-2q82-r87jRUSTSEC-2019-0038
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.57%1.14%1.72%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🦀libpulse-binding

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Duplicate Advisory

This advisory has been withdrawn because it is a duplicate of GHSA-xvcg-2q82-r87j. This link is maintained to preserve external references.

Original Description

Affected versions of this crate failed to catch panics crossing FFI boundaries via callbacks, which is a form of UB. This flaw was corrected by [this commit][1] which was included in version 2.6.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iolibpulse-bindingall versions2.6.0cargo update -p libpulse-binding --precise 2.6.0

Affected Products

1 product · 1 configurations
Application
libpulse-bindinglibpulse-binding_project
< 2.6.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for libpulse-binding, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update libpulse-binding to 2.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wcxc-jf6c-8rx9 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-xvcg-2q82-r87j. This link is maintained to preserve external references. ## Original Description Affected versions of this crate failed to catch panics crossing FFI boundaries via callbacks, which is a form of UB. This flaw was corrected by [this commit][1] which was included in version 2.6.0.
O3 Security · Impact-Aware SCA

Is GHSA-wcxc-jf6c-8rx9 in your dependencies?

Find it across crates.io, including transitive dependencies.

Duplicate Advisory: Uncaught Exception in libpulse-binding