NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Apache Santuario - XML Security for Java are vulnerable to private key disclosureGHSA-xfrj-6vvc-3xm2

MEDIUM

GHSA-xfrj-6vvc-3xm2 is a medium-severity (CVSS 6.5) CWE-532 vulnerability in org.apache.santuario:xmlsec. A fix is available for org.apache.santuario:xmlsec — see the affected versions and patch details below.

Also known asCVE-2023-44483
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-xfrj-6vvc-3xm2.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk+0.32%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.68%1.36%2.05%0.2%1.5%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.santuario:xmlsec☕org.apache.santuario:xmlsec☕org.apache.santuario:xmlsec

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

All versions of Apache Santuario - XML Security for Java prior to 2.2.6, 2.3.4, and 3.0.3, when using the JSR 105 API, are vulnerable to an issue where a private key may be disclosed in log files when generating an XML Signature and logging with debug level is enabled. Users are recommended to upgrade to version 2.2.6, 2.3.4, or 3.0.3, which fixes this issue.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.santuario:xmlsec≥ 2.3.0&&< 2.3.42.3.4org.apache.santuario:xmlsec:2.3.4
☕Mavenorg.apache.santuario:xmlsecall versions2.2.6org.apache.santuario:xmlsec:2.2.6
☕Mavenorg.apache.santuario:xmlsec≥ 3.0.0&&< 3.0.33.0.3org.apache.santuario:xmlsec:3.0.3

Affected Products

1 product · 3 configurations
Application
santuario xml security for javaapache
≥ 3.0.0 && < 3.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.santuario:xmlsec, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.santuario:xmlsec to 2.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xfrj-6vvc-3xm2 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat build of Apache Camel 3.20.6 for Spring BootsantuarioRHSA-2024:3708
Red Hat JBoss Enterprise Application Platformorg.apache.santuario/xmlsec:2.2.6.redhat-00002RHSA-2024:0714
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8eap7-eclipse-jgit-0:5.13.2-1.SP1_redhat_00001.1.el8eapRHSA-2024:0711
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9eap7-eclipse-jgit-0:5.13.2-1.SP1_redhat_00001.1.el9eapRHSA-2024:0712
Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7eap7-eclipse-jgit-0:5.13.2-1.SP1_redhat_00001.1.el7eapRHSA-2024:0710
Red Hat Single Sign-On 7see advisoryRHSA-2024:0804
Red Hat Single Sign-On 7.6 for RHEL 7rh-sso7-keycloak-0:18.0.12-1.redhat_00001.1.el7ssoRHSA-2024:0798
Red Hat Single Sign-On 7.6 for RHEL 8rh-sso7-keycloak-0:18.0.12-1.redhat_00001.1.el8ssoRHSA-2024:0799

Frequently Asked Questions

All versions of Apache Santuario - XML Security for Java prior to 2.2.6, 2.3.4, and 3.0.3, when using the JSR 105 API, are vulnerable to an issue where a private key may be disclosed in log files when generating an XML Signature and logging with debug level is enabled. Users are recommended to upgrade to version 2.2.6, 2.3.4, or 3.0.3, which fixes this issue.
O3 Security · Impact-Aware SCA

Is GHSA-xfrj-6vvc-3xm2 in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Santuario - XML Security for Java are vulnerable…