NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2013-4517 — xmlsec

Fix: apache/santuario-java@a09b904

CVE-2013-4517 is a CWE-399 vulnerability in org.apache.santuario:xmlsec. A fix is available for org.apache.santuario:xmlsec — see the affected versions and patch details below.

Improper Input Validation in Apache Santuario XML Security

Also known asGHSA-4p4w-6h54-g885
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
7.89%8.38%8.87%9.36%8.4%8.9%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.apache.santuario:xmlsec

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Santuario XML Security for Java before 1.5.6, when applying Transforms, allows remote attackers to cause a denial of service (memory consumption) via crafted Document Type Definitions (DTDs), related to signatures.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.santuario:xmlsecall versions1.5.6org.apache.santuario:xmlsec:1.5.6

Affected Products

1 product · 18 configurations
Application
santuario xml security for javaapache
≤ 1.5.5
17 versions
1.2.01.2.11.3.01.4.01.4.11.4.21.4.31.4.41.4.51.4.61.4.71.4.8

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.santuario:xmlsec, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.santuario:xmlsec to 1.5.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4517 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Fuse ESB 4, Fuse Message Broker 5.2, 5.3, 5.4, Fuse Mediation Router 2.7, 2.8 and Fuse Services Framework 2.3, 2.4 are now in a reduced support phase receiving only Critical impact security fixes. This issue has been rated as having Moderate security impact and is not currently planned to be addressed in future…

ProductFixed inAdvisory
JBEWP 5 for RHEL 5xml-security-0:1.5.6-3.ep5.el5RHSA-2014:1728
Red Hat JBoss BPMS 6.0xmlsecRHSA-2015:0851
Red Hat JBoss BRMS 6.0xmlsecRHSA-2015:0850
Red Hat JBoss Data Virtualization 6.1see advisoryRHSA-2015:0675
Red Hat JBoss Enterprise Application Platform 5.2xmlsecRHSA-2014:1725
Red Hat JBoss Enterprise Application Platform 5 for RHEL 5xml-security-0:1.5.6-3.ep5.el5RHSA-2014:1726
Red Hat JBoss Enterprise Application Platform 6.2xmlsecRHSA-2014:0172
Red Hat JBoss Enterprise Application Platform 6.2 for RHEL 5jbossas-javadocs-0:7.3.1-3.Final_redhat_3.ep6.el5RHSA-2014:0170

Frequently Asked Questions

Apache Santuario XML Security for Java before 1.5.6, when applying Transforms, allows remote attackers to cause a denial of service (memory consumption) via crafted Document Type Definitions (DTDs), related to signatures.
O3 Security · Impact-Aware SCA

Is CVE-2013-4517 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2013-4517: xmlsec DoS — Fixed in 1.5.6