CVE-2013-2172 — xmlsec
Fix: apache/santuario-java@25e0e11CVE-2013-2172 is a CWE-310 vulnerability in org.apache.santuario:xmlsec. A fix is available for org.apache.santuario:xmlsec — see the affected versions and patch details below.
Inefficient Algorithmic Complexity in Apache Santuario XML Security
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.santuario:xmlsec☕org.apache.santuario:xmlsecReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
jcp/xml/dsig/internal/dom/DOMCanonicalizationMethod.java in Apache Santuario XML Security for Java 1.4.x before 1.4.8 and 1.5.x before 1.5.5 allows context-dependent attackers to spoof an XML Signature by using the CanonicalizationMethod parameter to specify an arbitrary weak "canonicalization algorithm to apply to the SignedInfo part of the Signature."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.santuario:xmlsec | ≥ 1.4.0&&< 1.4.8 | 1.4.8org.apache.santuario:xmlsec:1.4.8 |
| ☕Maven | org.apache.santuario:xmlsec | ≥ 1.5.0&&< 1.5.5 | 1.5.5org.apache.santuario:xmlsec:1.5.5 |
Affected Products
santuario xml security for javaapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.santuario:xmlsec, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.santuario:xmlsec to 1.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2172 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Fuse ESB Enterprise 7.1.0 | see advisory | RHSA-2014:1369 |
| JBEWP 5 for RHEL 5 | xml-security-0:1.5.1-3_patch01.ep5.el5 | RHSA-2013:1219 |
| JBoss Enterprise BRMS Platform 5.3 | xmlsec | RHSA-2013:1375 |
| Red Hat JBoss Enterprise Application Platform 5.2 | see advisory | RHSA-2013:1218 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 5 | xml-security-0:1.5.1-3_patch01.ep5.el5 | RHSA-2013:1217 |
| Red Hat JBoss Enterprise Application Platform 6.1 | xmlsec | RHSA-2013:1209 |
| Red Hat JBoss Enterprise Application Platform 6 for RHEL 5 | apache-commons-beanutils-0:1.8.3-12.redhat_3.2.ep6.el5 | RHSA-2013:1207 |
| Red Hat JBoss Enterprise Application Platform 6 for RHEL 6 | apache-commons-beanutils-0:1.8.3-12.redhat_3.2.ep6.el6 | RHSA-2013:1208 |
Frequently Asked Questions
Is CVE-2013-2172 in your dependencies?
Find it across Maven, including transitive dependencies.