GHSA-x823-j7c4-vpc5 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in sickrage. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for sickrage — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for GHSA-x823-j7c4-vpc5.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
sickrageReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | sickrage | ≥ 9.3.54&&< 10.0.11.dev2 | 10.0.11.dev2pip install --upgrade 'sickrage==10.0.11.dev2' |
Affected Products
sickragesickrageResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sickrage, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sickrage to 10.0.11.dev2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x823-j7c4-vpc5 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-x823-j7c4-vpc5 in your dependencies?
Find it across PyPI, including transitive dependencies.