NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2018-9160 — sickrage

CRITICALFix: SickRage/SickRage@8156a74

CVE-2018-9160 is a critical-severity (CVSS 9.8) CWE-522 vulnerability in sickrage. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for sickrage — see the affected versions and patch details below.

SiCKRAGE Discloses Plaintext Credentials

Also known asGHSA-jrcv-3c5h-rh3qPYSEC-2018-101
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
75.6%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
73.5%74.7%76.0%77.2%74.2%75.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍sickrage

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

SickRage before v2018.03.09-1 includes cleartext credentials in HTTP responses.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsickrageall versions2018.03.09-1pip install --upgrade 'sickrage==2018.03.09-1'

Affected Products

1 product · 1 configurations
Application
sickragesickrage
≤ 9.2.101
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-44545webappslinux

SickRage < v2018.03.09 - Clear-Text Credentials HTTP Response

by Sven Fassbender · Apr 26, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sickrage, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sickrage to 2018.03.09-1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-9160 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

SickRage before v2018.03.09-1 includes cleartext credentials in HTTP responses.
O3 Security · Impact-Aware SCA

Is CVE-2018-9160 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2018-9160: sickrage — Fixed in 2018.03.09-1