NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2021-25925 — sickrage

MEDIUMFix: SiCKRAGE/SiCKRAGE@9f42426

CVE-2021-25925 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in sickrage. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for sickrage — see the affected versions and patch details below.

Cross-site scripting in SiCKRAGE

Also known asGHSA-rmp7-f2vp-3rq4PYSEC-2021-147
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2021-25925.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.77%1.16%0.2%0.7%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍sickrage

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsickrage≥ 4.2.0&&< 10.0.11.dev210.0.11.dev2pip install --upgrade 'sickrage==10.0.11.dev2'

Affected Products

1 product · 3 configurations
Application
sickragesickrage
≥ 4.2.0 && ≤ 10.0.11
1 version
10.0.11
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sickrage, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sickrage to 10.0.11.dev2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-25925 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.
O3 Security · Impact-Aware SCA

Is CVE-2021-25925 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2021-25925: sickrage XSS — Fixed in 10.0.11.dev2