Cross-site Scripting vulnerability in SimpleXLSXEx::readXfs and SimpeXLSX::toHTMLExGHSA-x6mh-rjwm-8ph7
MEDIUMFix: shuchkin/simplexlsx@cb4e716GHSA-x6mh-rjwm-8ph7 is a medium-severity (CVSS 6.8) Cross-site Scripting (XSS) vulnerability in shuchkin/simplexlsx. A fix is available for shuchkin/simplexlsx — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-x6mh-rjwm-8ph7.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
shuchkin/simplexlsxReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When calling the extended toHTMLEx method, it is possible to execute arbitrary JavaScript code.
Patches
The supplied patch resolves this vulnerability for SimpleXLSX. Use 1.1.12
Workarounds
Don't use direct publication via toHTMLEx
This vulnerability was discovered by Aleksey Solovev (Positive Technologies)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | shuchkin/simplexlsx | ≥ 1.0.12&&< 1.1.12 | 1.1.12composer require shuchkin/simplexlsx:^1.1.12 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shuchkin/simplexlsx, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shuchkin/simplexlsx to 1.1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x6mh-rjwm-8ph7 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-x6mh-rjwm-8ph7 in your dependencies?
Find it across Packagist, including transitive dependencies.