CVE-2024-55878 is a medium-severity (CVSS 6.8) Cross-site Scripting (XSS) vulnerability in shuchkin/simplexlsx. A fix is available for shuchkin/simplexlsx — see the affected versions and patch details below.
Cross-site Scripting vulnerability in SimpleXLSXEx::readXfs and SimpeXLSX::toHTMLEx
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-55878.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
shuchkin/simplexlsxReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
SimpleXLSX is software for parsing and retrieving data from Excel XLSx files. Starting in version 1.0.12 and prior to version 1.1.12, when calling the extended toHTMLEx method, it is possible to execute arbitrary JavaScript code. Version 1.1.12 fixes the issue. As a workaround, don't use direct publication via toHTMLEx.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | shuchkin/simplexlsx | ≥ 1.0.12&&< 1.1.12 | 1.1.12composer require shuchkin/simplexlsx:^1.1.12 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shuchkin/simplexlsx, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shuchkin/simplexlsx to 1.1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-55878 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-55878 in your dependencies?
Find it across Packagist, including transitive dependencies.