jsrsasign: DSA signatures or X.509 certificates can be forged via DSA domain-parameter validation in KJUR.crypto.DSA.setPublicGHSA-wvqx-v3f6-w8rh
HIGHFix: kjur/jsrsasign#646GHSA-wvqx-v3f6-w8rh is a high-severity (CVSS 7.4) CWE-347 vulnerability in jsrsasign. A fix is available for jsrsasign — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-wvqx-v3f6-w8rh.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.
jsrsasignnpmDescription
Versions of the package jsrsasign before 11.1.1 are vulnerable to Improper Verification of Cryptographic Signature via the DSA domain-parameter validation in KJUR.crypto.DSA.setPublic (and the related DSA/X509 verification flow in src/dsa-2.0.js). An attacker can forge DSA signatures or X.509 certificates that X509.verifySignature() accepts by supplying malicious domain parameters such as g=1, y=1, and a fixed r=1, which make the verification equation true for any hash.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | jsrsasign | all versions | 11.1.1npm install jsrsasign@11.1.1 |
Affected Products
jsrsasignkjurDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jsrsasign, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update jsrsasign to 11.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wvqx-v3f6-w8rh is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
IMPORTANT. The flaw in jsrsasign allows an attacker to forge Digital Signature Algorithm (DSA) signatures or X.509 certificates by providing malicious domain parameters during validation. This could lead to unauthorized access or data manipulation in affected Red Hat products such as Migration Toolkit for…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for GHSA-wvqx-v3f6-w8rh (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Migration Toolkit for Virtualization 2.10 | migration-toolkit-virtualization/mtv-console-plugin-rhel9:1779139872 | RHSA-2026:19409 |
| Migration Toolkit for Virtualization 2.9 | migration-toolkit-virtualization/mtv-console-plugin-rhel9:1778927462 | RHSA-2026:19410 |
| Red Hat Quay 3.10 | quay/quay-rhel8:1775169155 | RHSA-2026:6912 |
| Red Hat Quay 3.12 | quay/quay-rhel8:1775253092 | RHSA-2026:6720 |
| Red Hat Quay 3.15 | quay/quay-rhel8:1775169219 | RHSA-2026:6568 |
| Red Hat Quay 3.16 | quay/quay-rhel9:1779204086 | RHSA-2026:19375 |
| Red Hat Quay 3.9 | quay/quay-rhel8:1775169218 | RHSA-2026:6926 |
Frequently Asked Questions
Is GHSA-wvqx-v3f6-w8rh in your dependencies?
Find it across npm, including transitive dependencies.