NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-4600 — jsrsasign

Fix: kjur/jsrsasign@37b4c06

CVE-2026-4600 is a CWE-347 vulnerability in jsrsasign. A fix is available for jsrsasign — see the affected versions and patch details below.

jsrsasign: DSA signatures or X.509 certificates can be forged via DSA domain-parameter validation in KJUR.crypto.DSA.setPublic

Also known asGHSA-wvqx-v3f6-w8rh
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-4600.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs30th percentile — riskier than 30% of all scored CVEsHighest risk
0.00%0.29%0.57%0.86%0.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

jsrsasignnpm
2.3Mdownloads / week

Description

Versions of the package jsrsasign before 11.1.1 are vulnerable to Improper Verification of Cryptographic Signature via the DSA domain-parameter validation in KJUR.crypto.DSA.setPublic (and the related DSA/X509 verification flow in src/dsa-2.0.js). An attacker can forge DSA signatures or X.509 certificates that X509.verifySignature() accepts by supplying malicious domain parameters such as g=1, y=1, and a fixed r=1, which make the verification equation true for any hash.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmjsrsasignall versions11.1.1npm install jsrsasign@11.1.1

Affected Products

1 product · 1 configurations
Application
jsrsasignkjur
< 11.1.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jsrsasign, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update jsrsasign to 11.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-4600 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

IMPORTANT. The flaw in jsrsasign allows an attacker to forge Digital Signature Algorithm (DSA) signatures or X.509 certificates by providing malicious domain parameters during validation. This could lead to unauthorized access or data manipulation in affected Red Hat products such as Migration Toolkit for…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for CVE-2026-4600 (CC BY 4.0)
ProductFixed inAdvisory
Migration Toolkit for Virtualization 2.10migration-toolkit-virtualization/mtv-console-plugin-rhel9:1779139872RHSA-2026:19409
Migration Toolkit for Virtualization 2.9migration-toolkit-virtualization/mtv-console-plugin-rhel9:1778927462RHSA-2026:19410
Red Hat Quay 3.10quay/quay-rhel8:1775169155RHSA-2026:6912
Red Hat Quay 3.12quay/quay-rhel8:1775253092RHSA-2026:6720
Red Hat Quay 3.15quay/quay-rhel8:1775169219RHSA-2026:6568
Red Hat Quay 3.16quay/quay-rhel9:1779204086RHSA-2026:19375
Red Hat Quay 3.9quay/quay-rhel8:1775169218RHSA-2026:6926

Frequently Asked Questions

Versions of the package jsrsasign before 11.1.1 are vulnerable to Improper Verification of Cryptographic Signature via the DSA domain-parameter validation in KJUR.crypto.DSA.setPublic (and the related DSA/X509 verification flow in src/dsa-2.0.js). An attacker can forge DSA signatures or X.509 certificates that X509.verifySignature() accepts by supplying malicious domain parameters such as g=1, y=1, and a fixed r=1, which make the verification equation true for any hash.
O3 Security · Impact-Aware SCA

Is CVE-2026-4600 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-4600: jsrsasign — Fixed in 11.1.1