CVE-2026-4602 — jsrsasign
Fix: kjur/jsrsasign@5ea1c32CVE-2026-4602 is a CWE-681 vulnerability in jsrsasign. A fix is available for jsrsasign — see the affected versions and patch details below.
jsrsasign: Negative Exponent Handling Leads to Signature Verification Bypass
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-4602.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.
jsrsasignnpmDescription
Versions of the package jsrsasign before 11.1.1 are vulnerable to Incorrect Conversion between Numeric Types due to handling negative exponents in ext/jsbn2.js. An attacker can force the computation of incorrect modular inverses and break signature verification by calling modPow with a negative exponent.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | jsrsasign | all versions | 11.1.1npm install jsrsasign@11.1.1 |
Affected Products
jsrsasignkjurDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jsrsasign, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update jsrsasign to 11.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-4602 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This is an IMPORTANT flaw. The `jsrsasign` library, as used in Red Hat products such as Migration Toolkit for Virtualization and Red Hat Quay, is vulnerable to a signature verification bypass. A remote attacker could provide a specially crafted negative exponent to the `modPow` function, leading to incorrect modular…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-4602 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Migration Toolkit for Virtualization 2.10 | migration-toolkit-virtualization/mtv-console-plugin-rhel9:1779139872 | RHSA-2026:19409 |
| Migration Toolkit for Virtualization 2.9 | migration-toolkit-virtualization/mtv-console-plugin-rhel9:1778927462 | RHSA-2026:19410 |
| Red Hat Quay 3.10 | quay/quay-rhel8:1775169155 | RHSA-2026:6912 |
| Red Hat Quay 3.12 | quay/quay-rhel8:1775253092 | RHSA-2026:6720 |
| Red Hat Quay 3.15 | quay/quay-rhel8:1775169219 | RHSA-2026:6568 |
| Red Hat Quay 3.16 | quay/quay-rhel9:1779204086 | RHSA-2026:19375 |
| Red Hat Quay 3.9 | quay/quay-rhel8:1775169218 | RHSA-2026:6926 |
Frequently Asked Questions
Is CVE-2026-4602 in your dependencies?
Find it across npm, including transitive dependencies.