NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

Cross site scripting in publifyGHSA-wmh9-x28j-c6gr

MEDIUMFix: publify/publify@fefd5f7

GHSA-wmh9-x28j-c6gr is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in publify_core. A fix is available for publify_core — see the affected versions and patch details below.

Also known asBIT-publify-2021-25974CVE-2021-25974
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-wmh9-x28j-c6gr.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.00%0.37%0.73%1.10%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎publify_core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

In Publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS. A user with a “publisher” role is able to inject and execute arbitrary JavaScript code while creating a page/article.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspublify_core≥ 8.0&&< 9.2.59.2.5bundle update publify_core --conservative

Affected Products

1 product · 1 configurations
Application
publifypublify_project
≥ 8.0 && ≤ 9.2.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for publify_core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update publify_core to 9.2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wmh9-x28j-c6gr is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS. A user with a “publisher” role is able to inject and execute arbitrary JavaScript code while creating a page/article.
O3 Security · Impact-Aware SCA

Is GHSA-wmh9-x28j-c6gr in your dependencies?

Find it across RubyGems, including transitive dependencies.

Cross site scripting in publify (Medium 5.4)