NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2022-1812 — publify_core

HIGHFix: publify/publify@29a5837

CVE-2022-1812 is a high-severity (CVSS 7.6) CWE-190 vulnerability in publify_core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for publify_core — see the affected versions and patch details below.

Integer Overflow or Wraparound in publify/publify

Also known asBIT-publify-2022-1812GHSA-rc42-jghf-vr8f
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-1812.

EPSS Exploitation Probability

via FIRST.org ↗
30.8%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.00%13.3%26.6%39.9%0.5%30.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎publify_core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10 due to an unlimited length user name field.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspublify_coreall versions9.2.10bundle update publify_core --conservative

Affected Products

1 product · 1 configurations
Application
publifypublify_project
< 9.2.10
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for publify_core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update publify_core to 9.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1812 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10 due to an unlimited length user name field.
O3 Security · Impact-Aware SCA

Is CVE-2022-1812 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2022-1812: publify_core — Fixed in 9.2.10