NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2023-0299 — publify_core

HIGHFix: publify/publify@ca46da2

CVE-2023-0299 is a high-severity (CVSS 8.4) Improper Input Validation vulnerability in publify_core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for publify_core — see the affected versions and patch details below.

Improper Input Validation in publify/publify

Also known asBIT-publify-2023-0299GHSA-q3rm-f527-ghxj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-0299.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.96%1.44%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎publify_core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspublify_coreall versions9.2.10bundle update publify_core --conservative

Affected Products

1 product · 1 configurations
Application
publifypublify_project
< 9.2.10
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for publify_core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update publify_core to 9.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-0299 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
O3 Security · Impact-Aware SCA

Is CVE-2023-0299 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2023-0299: publify_core — Fixed in 9.2.10