NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actionsGHSA-wmcc-9vch-jmx4

HIGHFix: apache/cassandra@6207a30

GHSA-wmcc-9vch-jmx4 is a high-severity (CVSS 8.8) CWE-267 vulnerability in org.apache.cassandra:cassandra-all. A fix is available for org.apache.cassandra:cassandra-all — see the affected versions and patch details below.

Also known asBIT-cassandra-2025-23015CVE-2025-23015
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-wmcc-9vch-jmx4.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.01%1.51%0.4%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
☕org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-all

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.

This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2.

Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.cassandra:cassandra-all≥ 5.0-alpha1&&< 5.0.35.0.3org.apache.cassandra:cassandra-all:5.0.3
☕Mavenorg.apache.cassandra:cassandra-all≥ 4.1-alpha1&&< 4.1.84.1.8org.apache.cassandra:cassandra-all:4.1.8
☕Mavenorg.apache.cassandra:cassandra-all≥ 4.0-alpha1&&< 4.0.164.0.16org.apache.cassandra:cassandra-all:4.0.16
☕Mavenorg.apache.cassandra:cassandra-all≥ 3.1&&< 3.11.183.11.18org.apache.cassandra:cassandra-all:3.11.18
☕Mavenorg.apache.cassandra:cassandra-allall versions3.0.31org.apache.cassandra:cassandra-all:3.0.31

Affected Products

1 product · 5 configurations
Application
cassandraapache
≥ 5.0.0 && < 5.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.cassandra:cassandra-all, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.cassandra:cassandra-all to 5.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wmcc-9vch-jmx4 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
O3 Security · Impact-Aware SCA

Is GHSA-wmcc-9vch-jmx4 in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Cassandra: User with MODIFY permission on ALL…