CVE-2023-30601 is a high-severity (CVSS 7.8) Improper Privilege Management vulnerability in org.apache.cassandra:cassandra-all. A fix is available for org.apache.cassandra:cassandra-all — see the affected versions and patch details below.
Apache Cassandra: Privilege escalation when enabling FQL/Audit logs
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-30601.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-allReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Privilege escalation when enabling FQL/Audit logs allows user with JMX access to run arbitrary commands as the user running Apache Cassandra This issue affects Apache Cassandra: from 4.0.0 through 4.0.9, from 4.1.0 through 4.1.1.
WORKAROUND The vulnerability requires nodetool/JMX access to be exploitable, disable access for any non-trusted users.
MITIGATION Upgrade to 4.0.10 or 4.1.2 and leave the new FQL/Auditlog configuration property allow_nodetool_archive_command as false.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.cassandra:cassandra-all | ≥ 4.1.0&&< 4.1.2 | 4.1.2org.apache.cassandra:cassandra-all:4.1.2 |
| ☕Maven | org.apache.cassandra:cassandra-all | ≥ 4.0.0&&< 4.0.10 | 4.0.10org.apache.cassandra:cassandra-all:4.0.10 |
Affected Products
cassandraapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.cassandra:cassandra-all, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.cassandra:cassandra-all to 4.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-30601 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2023-30601 in your dependencies?
Find it across Maven, including transitive dependencies.