CVE-2025-23015 is a high-severity (CVSS 8.8) CWE-267 vulnerability in org.apache.cassandra:cassandra-all. A fix is available for org.apache.cassandra:cassandra-all — see the affected versions and patch details below.
Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-23015.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-allReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.
This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2.
Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.cassandra:cassandra-all | ≥ 5.0-alpha1&&< 5.0.3 | 5.0.3org.apache.cassandra:cassandra-all:5.0.3 |
| ☕Maven | org.apache.cassandra:cassandra-all | ≥ 4.1-alpha1&&< 4.1.8 | 4.1.8org.apache.cassandra:cassandra-all:4.1.8 |
| ☕Maven | org.apache.cassandra:cassandra-all | ≥ 4.0-alpha1&&< 4.0.16 | 4.0.16org.apache.cassandra:cassandra-all:4.0.16 |
| ☕Maven | org.apache.cassandra:cassandra-all | ≥ 3.1&&< 3.11.18 | 3.11.18org.apache.cassandra:cassandra-all:3.11.18 |
| ☕Maven | org.apache.cassandra:cassandra-all | all versions | 3.0.31org.apache.cassandra:cassandra-all:3.0.31 |
Affected Products
cassandraapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.cassandra:cassandra-all, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.cassandra:cassandra-all to 5.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-23015 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-23015 in your dependencies?
Find it across Maven, including transitive dependencies.