NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

Zope vulnerable to Stored Cross Site Scripting with SVG imagesGHSA-wm8q-9975-xh5v

LOWFix: zopefoundation/Zope@26a55db

GHSA-wm8q-9975-xh5v is a low-severity (CVSS 3.7) Cross-site Scripting (XSS) vulnerability in zope. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zope — see the affected versions and patch details below.

Also known asCVE-2023-42458PYSEC-2026-2077
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-wm8q-9975-xh5v.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.40%0.81%1.21%0.4%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍zope🐍zope

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

There is a stored cross site scripting vulnerability for SVG images.

Note that an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an image, and then trick a user into following a specially crafted link.

All versions of Zope are impacted on sites that allow untrusted users to upload images.

Patches

Patches will be released in Zope 4.8.10 and 5.8.5.

Workarounds

Make sure the "Add Documents, Images, and Files" permission is only assigned to trusted roles. By default only the Manager has this permission.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIzopeall versions4.8.10pip install --upgrade 'zope==4.8.10'
🐍PyPIzope≥ 5.8.0&&< 5.8.55.8.5pip install --upgrade 'zope==5.8.5'

Affected Products

1 product · 2 configurations
Application
zopezope
≥ 5.0.0 && < 5.8.5
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zope, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zope to 4.8.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wm8q-9975-xh5v is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact There is a stored cross site scripting vulnerability for SVG images. Note that an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an image, and then trick a user into following a specially crafted link. All versions of Zope are impacted on sites that allow untrusted users to upload images. ### Patches Patches will be released in Zope 4.8.10 and 5.8.5. ### Workarounds Make sure the "Add Documents, Images, and Files" permission is only assigned to trust
O3 Security · Impact-Aware SCA

Is GHSA-wm8q-9975-xh5v in your dependencies?

Find it across PyPI, including transitive dependencies.

Zope vulnerable to Stored Cross Site Scripting with SVG…