CVE-2023-42458 is a low-severity (CVSS 3.7) Cross-site Scripting (XSS) vulnerability in zope. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zope — see the affected versions and patch details below.
Zope vulnerable to Stored Cross Site Scripting with SVG images
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-42458.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
zope🐍zopeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
There is a stored cross site scripting vulnerability for SVG images.
Note that an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an image, and then trick a user into following a specially crafted link.
All versions of Zope are impacted on sites that allow untrusted users to upload images.
Patches
Patches will be released in Zope 4.8.10 and 5.8.5.
Workarounds
Make sure the "Add Documents, Images, and Files" permission is only assigned to trusted roles. By default only the Manager has this permission.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | zope | all versions | 4.8.10pip install --upgrade 'zope==4.8.10' |
| 🐍PyPI | zope | ≥ 5.8.0&&< 5.8.5 | 5.8.5pip install --upgrade 'zope==5.8.5' |
Affected Products
zopezopeResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zope, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zope to 4.8.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-42458 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-42458 in your dependencies?
Find it across PyPI, including transitive dependencies.