CVE-2002-0170 — zope
CVE-2002-0170 is a security vulnerability in zope. A fix is available for zope — see the affected versions and patch details below.
Zope does not properly verify the access for objects with proxy roles
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
zope🐍zopeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | zope | ≥ 2.2.0&&< 2.4.4 | 2.4.4pip install --upgrade 'zope==2.4.4' |
| 🐍PyPI | zope | ≥ 2.5.0&&< 2.5.1 | 2.5.1pip install --upgrade 'zope==2.5.1' |
Affected Products
zopezopeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zope, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zope to 2.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2002-0170 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Frequently Asked Questions
Is CVE-2002-0170 in your dependencies?
Find it across PyPI, including transitive dependencies.