NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2011-4924 — zope

MEDIUMFix: zopefoundation/Zope@37e4ea7

CVE-2011-4924 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in zope. A fix is available for zope — see the affected versions and patch details below.

Zope XSS Vulnerability

Also known asPYSEC-2026-3440PYSEC-2026-766
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.49%0.95%1.40%1.86%1.0%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍zope🐍zope2🐍zope2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIzope≥ 3.1.1&&< 3.7.33.7.3pip install --upgrade 'zope==3.7.3'
🐍PyPIzope2all versions2.12.22pip install --upgrade 'zope2==2.12.22'
🐍PyPIzope2≥ 2.13.0a1&&< 2.13.122.13.12pip install --upgrade 'zope2==2.13.12'

Affected Products

1 product · 6 configurations
Application
zopezope
≥ 3.1.1 && ≤ 3.4.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zope, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zope to 3.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4924 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104
O3 Security · Impact-Aware SCA

Is CVE-2011-4924 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2011-4924: zope XSS — Fixed in 3.7.3