NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

league/oauth2-server key exposed in exception message when passing as a string and providing an invalid pass phraseGHSA-wj7q-gjg8-3cpm

HIGHFix: thephpleague/oauth2-server#1353

GHSA-wj7q-gjg8-3cpm is a high-severity (CVSS 8.2) CWE-209 vulnerability in league/oauth2-server. A fix is available for league/oauth2-server — see the affected versions and patch details below.

Also known asCVE-2023-37260
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-wj7q-gjg8-3cpm.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.28%0.94%1.61%2.27%1.8%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘league/oauth2-server🐘league/oauth2-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Servers that passed their keys to the CryptKey constructor as as string instead of a file path will have had that key included in a LogicException message if they did not provide a valid pass phrase for the key where required.

Patches

This issue has been patched so that the provided key is no longer exposed in the exception message in the scenario outlined above. Users should upgrade to version 8.5.3 or 8.4.2 to receive the patch.

Workarounds

We recommend upgrading the oauth2-server to one of the patched releases (8.5.3 or 8.4.2). If you are unable to upgrade you can avoid this security issue by passing your key as a file instead of a string.

References

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistleague/oauth2-server≥ 8.3.2&&< 8.4.28.4.2composer require league/oauth2-server:^8.4.2
🐘Packagistleague/oauth2-server≥ 8.5.0&&< 8.5.38.5.3composer require league/oauth2-server:^8.5.3

Affected Products

1 product · 1 configurations
Application
oauth2-serverthephpleague
≥ 8.3.2 && < 8.5.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for league/oauth2-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update league/oauth2-server to 8.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wj7q-gjg8-3cpm is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Servers that passed their keys to the CryptKey constructor as as string instead of a file path will have had that key included in a LogicException message if they did not provide a valid pass phrase for the key where required. ### Patches This issue has been patched so that the provided key is no longer exposed in the exception message in the scenario outlined above. Users should upgrade to version 8.5.3 or 8.4.2 to receive the patch. ### Workarounds We recommend upgrading the oauth2-server to one of the patched releases (8.5.3 or 8.4.2). If you are unable to upgrade you can avoi
O3 Security · Impact-Aware SCA

Is GHSA-wj7q-gjg8-3cpm in your dependencies?

Find it across Packagist, including transitive dependencies.

GHSA-wj7q-gjg8-3cpm: oauth2-server — Fixed in 8.4.2