CVE-2023-37260 is a high-severity (CVSS 8.2) CWE-209 vulnerability in league/oauth2-server. A fix is available for league/oauth2-server — see the affected versions and patch details below.
league/oauth2-server key exposed in exception message when passing as string and providing invalid pass phrase
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-37260.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
league/oauth2-server🐘league/oauth2-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Servers that passed their keys to the CryptKey constructor as as string instead of a file path will have had that key included in a LogicException message if they did not provide a valid pass phrase for the key where required.
Patches
This issue has been patched so that the provided key is no longer exposed in the exception message in the scenario outlined above. Users should upgrade to version 8.5.3 or 8.4.2 to receive the patch.
Workarounds
We recommend upgrading the oauth2-server to one of the patched releases (8.5.3 or 8.4.2). If you are unable to upgrade you can avoid this security issue by passing your key as a file instead of a string.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | league/oauth2-server | ≥ 8.3.2&&< 8.4.2 | 8.4.2composer require league/oauth2-server:^8.4.2 |
| 🐘Packagist | league/oauth2-server | ≥ 8.5.0&&< 8.5.3 | 8.5.3composer require league/oauth2-server:^8.5.3 |
Affected Products
oauth2-serverthephpleagueDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for league/oauth2-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update league/oauth2-server to 8.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-37260 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-37260 in your dependencies?
Find it across Packagist, including transitive dependencies.