MediaWiki UnlinkedWikibase Cross-site Scripting vulnerabilityGHSA-wcx3-63mm-h8x6
MEDIUMFix: github/advisory-database#5310GHSA-wcx3-63mm-h8x6 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in samwilson/unlinked-wikibase. A fix is available for samwilson/unlinked-wikibase — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-wcx3-63mm-h8x6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
samwilson/unlinked-wikibaseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the UnlinkedWikibase extension in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1. XSS can occur through an interface message. Error messages (in the $err var) are not escaped before being passed to Html::rawElement() in the getError() function in the Hooks class.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | samwilson/unlinked-wikibase | all versions | 1.42.0composer require samwilson/unlinked-wikibase:^1.42.0 |
Affected Products
fedorafedoraprojectmediawikimediawikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for samwilson/unlinked-wikibase, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update samwilson/unlinked-wikibase to 1.42.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wcx3-63mm-h8x6 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-wcx3-63mm-h8x6 in your dependencies?
Find it across Packagist, including transitive dependencies.