NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-34500 — unlinked-wikibase

MEDIUMFix: github/advisory-database#5310

CVE-2024-34500 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in samwilson/unlinked-wikibase. A fix is available for samwilson/unlinked-wikibase — see the affected versions and patch details below.

MediaWiki UnlinkedWikibase Cross-site Scripting vulnerability

Also known asBIT-mediawiki-2024-34500GHSA-wcx3-63mm-h8x6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-34500.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘samwilson/unlinked-wikibase

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the UnlinkedWikibase extension in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1. XSS can occur through an interface message. Error messages (in the $err var) are not escaped before being passed to Html::rawElement() in the getError() function in the Hooks class.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsamwilson/unlinked-wikibaseall versions1.42.0composer require samwilson/unlinked-wikibase:^1.42.0

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
1 version
40
Application
mediawikimediawiki
≥ 1.41.0 && < 1.41.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for samwilson/unlinked-wikibase, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update samwilson/unlinked-wikibase to 1.42.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-34500 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in the UnlinkedWikibase extension in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1. XSS can occur through an interface message. Error messages (in the $err var) are not escaped before being passed to Html::rawElement() in the getError() function in the Hooks class.
O3 Security · Impact-Aware SCA

Is CVE-2024-34500 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-34500: unlinked-wikibase XSS — Fixed in 1.42.0