Podman has Files or Directories Accessible to External PartiesGHSA-vmhj-p9hw-vgrf
MEDIUMFix: containers/podman@c140ecdGHSA-vmhj-p9hw-vgrf is a medium-severity (CVSS 5.9) CWE-552 vulnerability in github.com/containers/podman. A fix is available for github.com/containers/podman — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/containers/podman🐹github.com/containers/podman/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was discovered in Podman where it incorrectly allows containers when created to overwrite existing files in volumes, even if they are mounted as read-only. When a user runs a malicious container or a container based on a malicious image with an attached volume that is used for the first time, it is possible to trigger the flaw and overwrite files in the volume. This issue was introduced in version 1.6.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/containers/podman | ≥ 1.6.0&&< 2.0.6 | 2.0.6go get github.com/containers/podman@v2.0.6 |
| 🐹Go | github.com/containers/podman/v2 | all versions | 2.0.6go get github.com/containers/podman/v2@v2.0.6 |
Affected Products
libpodlibpod_projectenterprise linuxredhatopenshift container platformredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containers/podman, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/containers/podman to 2.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vmhj-p9hw-vgrf is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Podman versions earlier than 1.6.0 are not affected. That includes the podman versions in OCP 4.2 and earlier.
If a volume needs to be attached as read-only to an untrusted container or container image, first attach it to a trusted container. Using the volume for the first time will make the attack impossible for other containers that are going to use the volume.Source: Red Hat security advisory for GHSA-vmhj-p9hw-vgrf (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | container-tools:rhel8-8020020200324071414.0d58ad57 | RHSA-2020:1650 |
| Red Hat OpenShift Container Platform 4.3 | podman-0:1.6.4-7.el8 | RHSA-2020:0680 |
| Red Hat OpenShift Container Platform 4.4 | openshift4/ose-aws-machine-controllers:v4.4.0-202004261927 | RHBA-2020:0581 |
Frequently Asked Questions
Is GHSA-vmhj-p9hw-vgrf in your dependencies?
Find it across Go, including transitive dependencies.