CVE-2020-14370 is a medium-severity (CVSS 5.3) CWE-212 vulnerability in github.com/containers/podman/v2. A fix is available for github.com/containers/podman/v2 — see the affected versions and patch details below.
Information disclosure in podman
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/containers/podman/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
An information disclosure vulnerability was found in containers/podman in versions before 2.0.5. When using the deprecated Varlink API or the Docker-compatible REST API, if multiple containers are created in a short duration, the environment variables from the first container will get leaked into subsequent containers. An attacker who has control over the subsequent containers could use this flaw to gain access to sensitive information stored in such variables.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/containers/podman/v2 | all versions | 2.0.5go get github.com/containers/podman/v2@v2.0.5 |
Affected Products
fedorafedoraprojectpodmanpodman_projectenterprise linuxredhatopenshift container platformredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containers/podman/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/containers/podman/v2 to 2.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-14370 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Whilst OpenShift Container Platform (OCP) does include podman, the Varlink API is not enabled by default. However, as it is trivial to activate this feature, OCP has been marked as affected. OCP 3.11 has previously packaged podman, but instead now relies on the version from rhel-extra.The older version previously…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 Extras | podman-0:1.6.4-26.el7_9 | RHSA-2020:5056 |
| Red Hat Enterprise Linux 8 | container-tools:rhel8-8030120210208205200.c127ee91 | RHSA-2021:0531 |
| Red Hat OpenShift Container Platform 4.6 | podman-0:1.9.3-3.rhaos4.6.el8 | RHSA-2020:4297 |
Frequently Asked Questions
Is CVE-2020-14370 in your dependencies?
Find it across Go, including transitive dependencies.