NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2024-9407 — buildah

MEDIUMFix: containers/buildah@e4e2ad5

CVE-2024-9407 is a medium-severity (CVSS 4.7) Improper Input Validation vulnerability in github.com/containers/buildah. A fix is available for github.com/containers/buildah — see the affected versions and patch details below.

Buildah: podman: improper input validation in bind-propagation option of dockerfile run --mount instruction

Also known asGHSA-fhqq-8f65-5xfcGO-2024-3169
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-9407.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.00%
Lower risk than most CVEs21th percentile — riskier than 21% of all scored CVEsHighest risk
0.00%0.26%0.53%0.79%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐹github.com/containers/buildah🐹github.com/containers/podman/v5🐹github.com/containers/podman🐹github.com/containers/podman/v2🐹github.com/containers/podman/v3🐹github.com/containers/podman/v4

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability exists in the bind-propagation option of the Dockerfile RUN --mount instruction. The system does not properly validate the input passed to this option, allowing users to pass arbitrary parameters to the mount instruction. This issue can be exploited to mount sensitive directories from the host into a container during the build process and, in some cases, modify the contents of those mounted files. Even if SELinux is used, this vulnerability can bypass its protection by allowing the source directory to be relabeled to give the container access to host files.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/containers/buildahall versions1.37.4go get github.com/containers/buildah@v1.37.4
🐹Gogithub.com/containers/podman/v5all versions5.2.4go get github.com/containers/podman/v5@v5.2.4
🐹Gogithub.com/containers/podmanall versions5.2.4go get github.com/containers/podman@v5.2.4
🐹Gogithub.com/containers/podman/v2all versions5.2.4go get github.com/containers/podman/v2@v5.2.4
🐹Gogithub.com/containers/podman/v3all versions5.2.4go get github.com/containers/podman/v3@v5.2.4
🐹Gogithub.com/containers/podman/v4all versions5.2.4go get github.com/containers/podman/v4@v5.2.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containers/buildah, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/containers/buildah to 1.37.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-9407 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This vulnerability is classified as moderate rather than important because it requires the attacker to have build privileges on the system, which inherently limits the scope of exploitation to trusted or semi-trusted users who already have some level of access. Additionally, while the flaw allows mounting and…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-9407 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 8container-tools:rhel8-8100020241023085649.afee755dRHSA-2024:8846
Red Hat Enterprise Linux 9podman-4:4.9.4-16.el9_4RHSA-2024:9051
Red Hat Enterprise Linux 9podman-4:5.2.2-9.el9_5RHSA-2024:9454
Red Hat Enterprise Linux 9buildah-2:1.37.5-1.el9_5RHSA-2024:9459
Red Hat Enterprise Linux 9.4 Extended Update Supportbuildah-2:1.33.11-1.el9_4RHSA-2024:9926
Red Hat OpenShift Container Platform 4.16openshift/ose-rhel-coreos-9:416.94.202411201433-0RHSA-2024:10147

Frequently Asked Questions

A vulnerability exists in the bind-propagation option of the Dockerfile RUN --mount instruction. The system does not properly validate the input passed to this option, allowing users to pass arbitrary parameters to the mount instruction. This issue can be exploited to mount sensitive directories from the host into a container during the build process and, in some cases, modify the contents of those mounted files. Even if SELinux is used, this vulnerability can bypass its protection by allowing the source directory to be relabeled to give the container access to host files.
O3 Security · Impact-Aware SCA

Is CVE-2024-9407 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2024-9407: buildah — Fixed in 1.37.4